Inability to create email channels with SendGrid

Incident Report for Xperience by Kentico

Resolved

Following our previous update, the issue has been fully resolved, and the system is now stable. We have completed our monitoring, and the incident is now closed.
Posted Feb 21, 2025 - 09:14 CET

Monitoring

The fix has been applied and our services are fully operational.
We had to adjust our implementation to accommodate the change in the SendGrid API behavior. This allowed us to resume normal operations.
We are actively monitoring the situation to ensure stability.
Posted Feb 20, 2025 - 12:48 CET

Identified

After a complex troubleshooting process we concluded that the issue is caused by an unexpected change in the SendGrid API behaviour, and we are working on fix. We will apply the fix to our systems as soon as it is ready and thoroughly tested.
Posted Feb 18, 2025 - 21:06 CET

Investigating

Our monitoring system detected a problem with SendGrid that's preventing our SaaS customers from creating a new email channel or applying a custom domain to their existing email channels. Currently configured email channels are not affected and are functioning normally. We are working with SendGrid Support to resolve the issue and we will provide a new update soon.
Posted Feb 13, 2025 - 17:56 CET
This incident affected: Xperience Portal.