Deployments with db and/or storage changes failing

Incident Report for Xperience by Kentico

Postmortem

Deployment pipeline agents were unable to retrieve the AzCopy dependency, which is required for deployments involving database and/or storage changes.
The issue was caused by a contract change on a third-party side used by the pipeline to download AzCopy.
A hotfix was applied to the deployment pipeline to resolve the issue.

Posted Aug 07, 2025 - 08:29 CEST

Resolved

Hotfix has been applied to deployment pipelines.
Posted Aug 07, 2025 - 07:56 CEST

Identified

Deployment pipeline agents are unable to get azcopy dependency which is required for deployments with db and/or storage changes,
Deployments without db or storage changes working.
Posted Aug 07, 2025 - 06:44 CEST

Investigating

We are investigating the issue
Posted Aug 07, 2025 - 06:20 CEST
This incident affected: Deployment API.