Deployment pipelines were failing in cases where a new deployment package was uploaded or an offline deployment was required. The deployment pipeline requires the AzCopy utility dependency in these cases, however the AzCopy download link was broken by the third-party provider and the pipeline was unable to resolve the new version 10.31.0.
We mitigated the issue by releasing a hotfix that directs the download link to a specific previous version of AzCopy.
Posted Nov 11, 2025 - 11:41 CET
Resolved
The hotfix has been applied to the deployment pipeline.
Posted Nov 10, 2025 - 12:58 CET
Monitoring
Hotfix has been applied to the deployment pipeline.
Posted Nov 10, 2025 - 12:21 CET
Identified
Deployment pipelines are failing in some cases (new deployment packages or storage/database changes in the deployment package) due to not being able to download the azcopy utility dependency. azcopy version 10.31.0 cannot be resolved correctly (https://github.com/Azure/azure-storage-azcopy/issues/3284).