Cloudflare Global Network outage

Incident Report for Xperience by Kentico

Postmortem

One of our core 3rd party dependencies Cloudflare experienced an outage and failed to deliver core network traffic. More about the Cloudflare incident can be read in their Postmortem.

The Cloudflare outage impacted all of our customer’s domains which are routed through Cloudflare by default causing all of our customer’s websites to be unavailable. Additionally, the Xperience Portal (also routed through Cloudflare) was made unavailable which not only impacted the Xperience Portal UI but also the Deployments API.

Cloudflare eventually recovered their services and we did not record any further availability drops.

Posted Nov 19, 2025 - 14:28 CET

Resolved

Cloudflare states their services are operating normally now.
Posted Nov 18, 2025 - 19:20 CET

Update

Cloudflare has applied a fix, and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services return to normal.
Posted Nov 18, 2025 - 16:16 CET

Monitoring

Cloudflare has recovered its services, but customers may continue to see higher-than-normal error rates due to their remediation efforts.
Posted Nov 18, 2025 - 13:32 CET

Investigating

Cloudflare's global network is currently experiencing an outage, and some of the cloud infrastructure, including customers' websites, are not available.

See: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 13:07 CET
This incident affected: Xperience Portal, Deployment API, West Europe (Production sites), UK South (Production sites), East US (Production sites), Southeast Asia (Production sites), Australia East (Production sites), Canada Central (Production sites), East Asia (Hong Kong) (Production sites), Germany West Central (Production sites), Japan East (Production sites), North Europe (Ireland) (Production sites), UAE North (Production sites), East US 2 (Production sites), West US (Production sites), West US 2 (Production sites), Canada East (Production sites), Japan West (Production sites), North Central US (Production sites), Australia Southeast (Production sites), UK West (Production sites), and Switzerland North (Production sites).